Majority of screenshot devices are not returning results or are unavailable for email preview testing at this time.

Incident Report for Email on Acid

Resolved

This incident has been resolved.
Posted May 15, 2025 - 14:53 UTC

Update

Majority of devices are now available for testing and we are continuing to monitor.
Posted May 15, 2025 - 14:04 UTC

Monitoring

A fix has been implemented and we are monitoring the results. Majority of devices are still unavailable for screenshots at this time.
Posted May 15, 2025 - 13:54 UTC

Investigating

We are currently investigating this issue and will update as we have more information.
Posted May 15, 2025 - 13:33 UTC